【Minecraft】1.5.1以降にMODを導入しても初期化されてバニラ状態に!? 新ランチャーを解明! その2【重要】
閉じる
閉じる

新しい記事を投稿しました。シェアして読者に伝えましょう

×

【Minecraft】1.5.1以降にMODを導入しても初期化されてバニラ状態に!? 新ランチャーを解明! その2【重要】

2013-05-04 21:15
  • 23
  • 89
先日投稿しました http://ch.nicovideo.jp/minecrafter/blomaga/ar216979 の記事は
多くの方にご覧いただきました。
皆様のお役に立てれば、と思っております。

さて、先日投稿した記事のコメントに、このような投稿がございました。

Ver.1.5.2でMODいれたら、毎回Jarが初期化されるっぽいのです・・・


嘘・・・だろ・・・?


このコメントを受け、Ver1.5.2に、軽量化MODである「Optifine」を導入し、起動すると
確かにMODが初期化され、Optifineのない状態で起動されてしまいました。

これは回避方法を見つけないとヤバイ!
ヤバイと思ったが回避方法がないのでMODを導入できなかった・・・。
(↑無理やりネタを押し込もうとした結果がこれだよ)

回避方法はあります。
実際試してみましたが、ある意味でこれは便利なのかもしれない・・・。

この方法もやはり、非公式です。作業は自己責任でお願い致します。


まず、わかりやすい名前のフォルダを作ります。
ただし、半角英数字、ドット(.)以外を使用しないでください。





フォルダの中に、MODを導入した jar本体 と、
1.5.2フォルダの中からコピーしてきた 1.5.2.json を入れてあげます。
jar本体は フォルダ名.jar にリネームしてあげます。





1.5.2.jsonをワードパッドで開き、
2行目の 1.5.2 を、フォルダ名に合わせて書き換えます。





保存した "1.5.2.json" を "フォルダ名.json" にリネームします。





さて、これで Optifine を入れて、起動してみましょう。
ちゃんと、Version選択の中に入っているハズです。





バニラ状態に初期化されることなくOptifineが残っていました!
これで問題なくMODを導入した状態でランチャーから起動できます。



この作業、面倒そうに見えて、実は利点があります。

そう、 バニラ状態のMODを誤って消すことがない という点と、
名前をつけることで、どのjarにどのMODが入っているか一目瞭然にできる、という点です。

恐らく仕組みとしては、起動する際にjar本体のチェックを行い、
META-INF が無いと、バニラ状態の本体を再度ダウンロードして起動するという仕組みになっているのだと思われます。
そのため、バージョン名.jsonの2行目のIDが 1.5.1 や 1.5.2 の場合、
minecraft.netからバニラ状態の本体をDLしてきてしまうようです。
1.4.7以前は、minecraft.netのサーバー上に本体がないため、そのまま起動するのだと思われます。

そのため、1.5.1以降はバニラ状態のバックアップを取らずにMODを入れてしまっても、
ランチャーから起動してあげる事で、再度バニラ状態に戻すことができる、というわけです。
これで、導入ミスなどでバニラ状態のjar本体を紛失するという危険性が減りますね。

ただし、新しいバージョンがリリースされるにつれ、古いバージョンのバニラ本体がDLできなくなってしまう(例えば、1.6がリリースされると同時に1.5.1のバニラ本体がminecraft.netのサーバー上からDL不可になる)可能性があるので、バックアップはしっかりと自分で保管しておきましょう。

また、フォルダを分けることで、ランチャーから指定のものを選択して起動できる利点上、
起動したい本体を、従来のようにminecraft.jarをリネームしてあげたり、
分類ソフトを使用することなく、スムーズにMOD入りの本体やバニラ状態の本体を起動できるというのも、便利な点かもしれません。

ちょっとの手間をかけるだけで、何かと便利に!
みなさんも新ランチャーに慣れるために、完全移行前に少し試してみてはいかがでしょうか。
Dev版のランチャーは こちら からDLすることができます。


ブロマガに投稿されたコメントは、私は欠かさずチェックしております。
何かありましたらコメントを利用し、私や、他のユーザーの助けを是非もらってください!

ところでmojangさん、MODAPIの話はどこにいってしまわれたのですか・・・?

広告
他13件のコメントを表示
×
というよりもまずModloaderとかどこに入れればいいんですか?
15ヶ月前
×
13w21aでjsonファイルが生成されなくなてしまったのでこの記事の方法はもう使えないです
15ヶ月前
×
No.16さんがおっしゃっている通り、jsonファイルが生成されなくなってしまったようですね。新たなMOD導入方法の検証よろしくお願いします。
15ヶ月前
×
>>10
>>11

新ランチャーで1.2.5以前のマインクラフトを起動させる方法をコメントに載せておきましたので、
是非ご覧ください。

http://ch.nicovideo.jp/minecrafter/blomaga/ar216979
14ヶ月前
×
バージョンが選べなくなりました…
14ヶ月前
×
↑自己解決
プロフィールエディターから
useversionで変更できるようです
14ヶ月前
×
>>16
俺は13w25c等できてるけど…
13w21a以降ってことですよね?
14ヶ月前
×
新しく配布されたランチャー?だとそもそも起動できない状態なんですが…
久しぶりに新ランチャー起動させたらDLしてくれみたいな感じだったのでDLしたら名前変えたバージョンのものはゲーム開始できなくなってしまった…
14ヶ月前
×
あ、新しい記事があったのですか…
yahooからの検索で見つけたため気づきませんでした…
失礼
14ヶ月前
×
Launcher 1.0.4以降でも同様の方法でできることを確認しました。
13ヶ月前
コメントを書く
コメントをするには、
ログインして下さい。